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NX3 Unigraphics
Datum Tools

How to :
Create Datum plane. Insert > Datum/ point > Datum plane > OK

     offset Insert > Datum/ point > Datum plane >Constraints Cascade Menu > offset > OK

     angular offset Insert > Datum/ point > Datum plane >Constraints Cascade Menu > angle > OK

Create Datum Axis. Insert > Datum/ point > Datum axis > OK

Create Datum point on:

     Curve Insert > Datum/ point > Point Set > Points on Curve > OK

     Edge Insert > Datum/ point > Point Set > Points on Curve > OK

     Datum Axis N/A

     Curve's Intersection Insert > Datum/ point > Point Set > Points on Curve > OK

     At Center Insert > Datum/ point > Point > Select Arc/ Circle > OK

     On/ Offset from a surface Insert > Datum/ point > Point Set > Points on face > OK

     Offset from other points Insert > Datum/ point > Point Set > Points on face > OK

     Intersecting entities Insert > Datum/ point > Point > Points on intersection > OK

Create Sketched Datum Curve Insert > Curve > Pick type of line to sketch > OK

Create Coordinate System

     Locate Insert > Datum CSYS > Pick type > OK

     Offset Insert > Datum CSYS > Pick Offset type in CSYS Constructor > OK

     Orient Insert > Datum CSYS > Pick Oriented type in CSYS Constructor > OK

     From File N/A

Feature Creation Tools

How to :
Create an Extrusion

     Solid Insert > Design Feature > Extrude > Select sketched geometry > OK

     Thick Insert > Design Feature > Extrude > Select sketched geometry > Offset to thicken > OK

     Cut Insert > Design Feature > Extrude > Select sketched geometry > Boolean Subtract > OK

     Surface Insert > Design Feature > Extrude > Select sketched open geometry > Offset to thicken > OK

     Surface Trim Insert > Design Feature > Extrude > Select sketched geometry > Boolean Subtract > OK

     Revolved Solid Insert > Design Feature > Revolve > follow cues > OK

     Thick Revolved Feature Insert > Design Feature > Revolve > follow cues > OK

     Revolved Cut Insert > Design Feature > Revolve >Boolean Subtract, follow cues > OK

     Revolved Surface Insert > Design Feature > Revolve >Offset,  follow cues > OK

     Revolved Surface Trim Insert > Design Feature > Revolve >Boolean Subtract,  follow cues > OK

     Variable Section Sweep Insert > Sweep > Swept > follow cues > OK

Create a Blend

     Basic Insert > Detail feature > Edge Blend > follow cues > OK

     Import N/A

Edit Feature Tools

How to :
Copy a Feature

     Surface Edit > Copy feature > select surface > OK

          Without Holes and Patches Edit > Copy feature > select surface > OK

          Bounded by a Closed Curv Edit > Copy feature > select surface > OK

     Curves Edit > Copy feature > select curve > OK

     Edges Edit > Copy feature > select edge > OK

     Mirror

          Part Geometry Insert > Associative Copy > Instance > Mirror Body > follow cues > OK

          Selectable Features Insert > Associative Copy > Instance > Mirror feature > follow cues > OK

Miscellaneous Tools

How to :
Move Entities

     Surface Edit > Feature > Move > Select surface > move > OK

     Curves Edit > Feature > Move > Select curve > move > OK

     Axis Edit > Feature > Move > Select axis > move > OK



NX3 Unigraphics
Rotate Entities

     Surface Edit > Feature > Move > Select surface > rotate between two axes > OK

     Curves Edit > Feature > Move > Select curve > rotate between two axes > OK

Merge Entities

     Selected Features Insert > Combine Bodies > Unite > OK

Trim Entities

     Curves Insert > Combine Bodies > Subtract  > OK

     Surfaces Insert > Combine Bodies > Subtract  > OK

Pattern Features

     Dimension Insert > Associative Copy > Instance > Mirror feature > follow cues > OK

     Table Insert > Associative Copy > Instance > Mirror feature > follow cues > OK

     Reference Insert > Associative Copy > Instance > Mirror feature > follow cues > OK

Projections

     Datum Curves

          By sketch Insert > Curve from Curves > Project > follow cues > OK

          By selection Insert > Curve from Curves > Project > follow cues > OK

Create a Wrap

     Datum Curves Insert > Offset/scale > Wrap geometry > OK

Create Extensions

     Surface Insert > Trim > Trim and Extend > choose surface > OK

     Tangent Surfaces Insert > Trim > Trim and Extend > choose surface > OK

     To a Plane Insert > Trim > Trim and Extend > choose surface > OK

Create Intersections from

     Sketches Insert > Curve from Bodies > Intersect > select sketches > OK

     Surfaces Insert > Curve from Bodies > Intersect > select surface > OK

Create Fills Insert > Combine Bodies > Patch   OR  Insert > Surface > Transition > OK for Non planar surfaces

Redefine a Fills Select Transition or Patch in Feature tree > right click > Edit  > follow cues >OK

Create Offset 

     Surface

          Standard Insert > Offset/ scale > offset > select surfaces > OK

          Expanded Insert > Offset/ scale > offset > select surfaces > OK

          Constraints Insert > Offset/ scale > offset > select surfaces > OK

          Drafts Insert > Offset/ scale > offset > select surfaces > OK

          Replacing Insert > Offset/ scale > offset > select surfaces > OK

     Curves

          Normal Insert > Offset/ scale > offset > select curve > OK

          Along Insert > Offset/ scale > offset > select curve > OK

          Fan Curve Insert > Offset/ scale > offset > select curve > OK

          Boundary Insert > Offset/ scale > offset > select curve > OK

          Variable Boundary Insert > Offset/ scale > offset > select curve > OK

Create a Thicken Insert > Offset/ scale > Thicken sheet > select surface > OK

Create a Solid on surfaces

     Protrusion Insert > Offset/ scale > Sheets to a solid assistant > select surface> Boolean Create > OK

     Cut Insert > Offset/ scale > Sheets to a solid assistant > select surface> Boolean Subtract > OK

     Patches Insert > Offset/ scale > Sheets to a solid assistant > select surface> Boolean Unite > OK

Create Holes 

     Sketched Insert > Design Feature > Extrude subtract > Sketch hole,  follow cues > OK

     Simple Insert > Design Feature > Hole > Simple,  follow cues > OK

     Counterbore Insert > Design Feature > Hole > Counterbore,  follow cues > OK

     Countersunk Insert > Design Feature > Hole > Countersunk,  follow cues > OK

Create Shells

     Shells Insert > Offset/ scale > Hollow > select surface/s to pierce > OK

Create Ribs

     Ribs Use freeform features to create.

Create Drafts

     Standard Insert > Detail feature > Taper select type> OK

     Variable Insert > Detail feature > Taper select type> OK

     Split Insert > Detail feature > Taper select type> OK

          Split with 2 Hinge Planes Insert > Detail feature > Taper select type> OK

Create Rounds

     Basic Insert > Detail feature > Edge Blend  select type > OK

Create Chamfers

     Basic Insert > detail feature > chamfer > OK
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Pro-Engineer Wildfire
Datum Tools

How to :
Create Datum plane. Insert > Model Datum > Plane> choose constraints> OK

     offset Insert > Model Datum > Plane> select existing Plane/ planar surface> OK

     angular offset Insert > Model Datum > Plane> select existing Axis/ Edge> select Through> Offset Rotation > OK

Create Datum Axis. Insert > Model Datum > Axis> select two references (planes, surfaces, points, curves)> OK

Create Datum point on:

     Curve Select an entity (Curve) > select points Icon>Placement > OK

     Edge Select an entity (edge) > select points Icon>Placement > OK

     Datum Axis Select an entity (Datum axis)> select point Icon>Placement > OK

     Curve's Intersection Select an entity (2 curves)> select point Icon>Placement > OK

     At Center Select an entity (arc, circular geometry)> select point Icon>Placement > OK

     On/ Offset from a surface Select an entity (surface)> select point Icon>Placement > in the offset dimension box type value> OK

     Offset from other points Select an entity (point)> select point Icon>Placement > in the offset dimension box type value> OK

     Intersecting entities Select 2 intersecting entities> select point Icon>Placement > in the offset dimension box type value> OK

Create Sketched Datum Curve Insert > Model Datum > Sketched Curve 

Create Coordinate System

     Locate Insert > Model Datum > Coordinate System 

     Offset Insert > Model Datum > Coordinate System > click offset Tab type x,y,z distances > OK

     Orient Insert > Model Datum > Coordinate System > in orient Tab  > OK

     From File Insert > Model Datum > Coordinate System > Select from file in menu > OK

Feature Creation Tools

How to :
Create an Extrusion

     Solid Insert > Extrude > follow cues > OK

     Thick Insert > Extrude > follow cues > click on the thicken button> OK

     Cut Insert > Extrude > follow cues > click on the remove material button> OK

     Surface Insert > Extrude > follow cues > click on the surface button> OK

     Surface Trim Insert > Extrude > follow cues > click on the surface button> click remove material button> OK

     Revolved Solid Insert > Revolve > follow cues >  OK

     Thick Revolved Feature Insert > Revolve > follow cues > click on the thicken button> OK

     Revolved Cut Insert > Revolve > follow cues > click on the remove material button> OK

     Revolved Surface Insert > Revolve > follow cues > click on the surface button> OK

     Revolved Surface Trim Insert > Revolve > follow cues > click on the surface button> click remove material button> OK

     Variable Section Sweep Insert > Variable Section Sweep > click surface/ solid button > follows cues > OK

Create a Blend

     Basic Insert> Blend > blend opts > Done  

     Import Insert> Blend > blend opts > from file > Done  

Edit Feature Tools

How to :
Copy a Feature

     Surface Click Edit > Copy > OK

          Without Holes and Patches Click Edit > Copy > right click Exclude Surfaces and fill holes >  OK

          Bounded by a Closed Curve Click Edit > Copy > right click  Copy Inside Boundary  >  OK

     Curves Click Edit > Copy > right click  Approximate/ Exact >  OK

     Edges Click Edit > Copy > right click  Approximate/ Exact >  OK

     Mirror

          Part Geometry Select part name from the Model Tree > Edit > Mirror > select mirror plane > OK

          Selectable Features Select features > Edit > Mirror > select mirror plane > OK

How to :
Move Entities

     Surface Select surface > Edit > Move > translate, follow cues > OK

     Curves Select curve > Edit > Move > translate, follow cues > OK

     Axis Select axis > Edit > Move > translate, follow cues > OK



Pro-Engineer Wildfire
Rotate Entities

     Surface Select surface > Edit > Move > Rotate, follow cues > OK

     Curves Select curve > Edit > Move > Rotate, follow cues > OK

Merge Entities

     Selected Features Select 2 surfaces > Edit > Merge > Select method to merge, follow cues > OK

Trim Entities

     Curves Select Curve > Edit > Trim > Select direction, follow cues > OK

     Surfaces Select Surfaces > Edit > Trim > Select Options Thin Trim, follow cues > OK

Pattern Features

     Dimension Select Feature to pattern > Edit > Pattern > Select dimension to pattern to, follow cues > OK

     Table Select Feature to pattern > Edit > Pattern > Select table as method , follow cues > OK

     Reference Select Feature to pattern > Edit > Pattern > Select reference as method , follow cues > OK

Projections

     Datum Curves

          By sketch Edit > Project > References tab > Select a sketch > follow cues > OK

          By selection Edit > Project > References tab > Select chains > follow cues > OK

Create a Wrap

     Datum Curves Edit > Wrap > click Destination > follow cues > OK

Create Extensions

     Surface Select edges of Surfaces > Edit > Extend > Select Options Same, follow cues > OK

     Tangent Surfaces Select edges of Surfaces > Edit > Extend > Select Options Tangent, follow cues > OK

     To a Plane Select edges of Surfaces > Edit > Extend > Select Options To Plane, follow cues > OK

Create Intersections from

     Sketches  Edit >Definition > Collect sketch, follow cues > OK

     Surfaces  Edit >Definition > Collect surface, follow cues > OK

Create Fills Select datum curve >Edit > Fill > click continue, follow cues > OK

Redefine a Fills Select fill feature in Tree > right click >Edit Definition > click continue, follow cues > OK

Create Offset 

     Surface

          Standard Edit > Offset > enter value for offset > select standard for type > OK

          Expanded Edit > Offset > enter value for offset > select expand for type > OK

          Constraints Edit > Offset > enter value for offset > select expand for type > sketched Region > OK

          Drafts Edit > Offset > enter value for offset > select with drafts for type > select sketch, follow cues > OK

          Replacing Edit > Offset > enter value for offset > select replace for type > select sketch, follow cues > OK

     Curves

          Normal Edit > Offset > enter value for offset > Reference tab > select Normal to surface, follow cues > OK

          Along Edit > Offset > enter value for offset > Reference tab > select Along to surface, follow cues > OK

          Fan Curve Edit > Offset  > Reference tab > select Parallel to plane, follow cues > OK

          Boundary Edit > Offset  > enter value for offset> Reference tab >, follow cues > OK

          Variable Boundary Edit > Offset  > enter value for offset> Reference tab >, follow cues > OK

Create a Thicken Edit > Thicken  > enter value > follow cues > OK

Create a Solid on surfaces

     Protrusion Edit > Solidify  > select surface > Add material, follow cues > OK

     Cut Edit > Solidify  > select surface >  Remove material, follow cues > OK

     Patches Edit > Solidify  > select surface >  Remove/ Add material, follow cues > OK

Create Holes 

     Sketched Insert > Hole > Sketched > follow cues > OK

     Simple Insert > Hole > click Simple Icon > follow cues > OK

     Counterbore Insert > Hole > click Counterbore Icon > follow cues > OK

     Countersunk Insert > Hole > click Countersunk Icon > follow cues > OK

Create Shells

     Shells Insert > Shell  > follow cues > OK

Create Ribs

     Ribs Insert > Rib  > follow cues > OK

Create Drafts

     Standard Insert > Draft > Select hinges > follow cues > OK

     Variable Insert > Draft > Select hinges > follow cues > OK

     Split Insert > Draft > Select hinges > select split, follow cues > OK

          Split with 2 Hinge Planes Insert > Draft > Select hinges > select split by split object, follow cues > OK

Create Rounds

     Basic Insert > Round > enter round dimension > follow cues > OK

Create Chamfers

     Basic Insert > Chamfer > Edge Chamfer, follow cues > OK
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Solidworks 2004
Datum Tools

How to :
Create Datum plane. Insert > Reference Geometry > Plane.

     offset Insert > Reference Geometry > Plane > Offset

     angular offset Insert > Reference Geometry > Plane > At Angle

Create Datum Axis. Insert > Reference Geometry > Axis

Create Datum point on:

     Curve Insert > Reference Geometry > Point > select curve, follow cues > OK

     Edge Insert > Reference Geometry > Point > select edge, follow cues > OK

     Datum Axis Insert > Reference Geometry > Point > select axis, follow cues > OK

     Curve's Intersection Insert > Reference Geometry > Point > select intersection, follow cues > OK

     At Center Insert > Reference Geometry > Point > select center of face, follow cues > OK

     On/ Offset from a surface Insert > Reference Geometry > Point > select projection, follow cues > OK

     Offset from other points Insert > Reference Geometry > Point > select along curve, follow cues for distance > OK

     Intersecting entities Insert > Reference Geometry > Point > select intersection, follow cues > OK

Create Sketched Datum Curve Insert > Curve > make it a datum > OK

Create Coordinate System

     Locate Insert > Reference Geometry > Coordinate System > OK

     Offset Insert > Reference Geometry > Coordinate System > type in x,y,z values > OK

     Orient Insert > Reference Geometry > Coordinate System > reverse axis direction > OK

     From File Insert > Reference Geometry > Coordinate System > OK

Feature Creation Tools

How to :
Create an Extrusion

     Solid Insert > Boss/Base > Extrude > OK

     Thick Insert > Boss/Base > Extrude > select Thin feature > OK

     Cut Insert > Cut > Extrude > input end conditions > OK

     Surface Insert > Boss/Base > Extrude > select thin > input end conditions > OK

     Surface Trim Insert > Cut > With Surface > Follow cues > OK

     Revolved Solid Insert > Boss/Base > Revolved  > select axis of rotation > input end conditions > OK

     Thick Revolved Feature Insert > Boss/Base > Revolved  > select thin feature >select axis of rotation > input end conditions > OK

     Revolved Cut Insert > Cut > Revolved > follow cues > OK

     Revolved Surface Insert > Surface > Revolve > select axis > select add material >follow cues > OK

     Revolved Surface Trim Insert > Surface > Revolve > select axis > select remove material > follow cues > OK

     Variable Section Sweep Insert > Boss/Base > Sweep > follow cues > OK

Create a Blend

     Basic Insert > Features > Fillet/Round > select type > enter radius > follow cues > OK

     Import

Edit Feature Tools

How to :
Copy a Feature

     Surface Edit > Copy > Select surface > click where you want to paste surface > paste > OK

          Without Holes and Patches N/A

          Bounded by a Closed Curv N/A

     Curves Edit > Copy > Select curve > click where you want to paste curve > paste > OK

     Edges Edit > Copy > Select edge > click where you want edge > paste > OK

     Mirror

          Part Geometry Insert > Pattern/Mirror > Mirror > select plane > select parts to be mirror > OK

          Selectable Features Insert > Pattern/Mirror > Mirror > select plane > select features to be mirror > OK

How to :
Move Entities

     Surface Insert > Surface > Move/ Copy > follow cues > OK

     Curves Insert > Features > Move/ Copy > follow cues > OK

     Axis Click on Axis > Right click > Edit feature > follow cues > OK



Solidworks 2004
Rotate Entities

     Surface Insert > Move/ Copy Bodies > Select surface > rotate > OK

     Curves Insert > Move/ Copy Bodies > Select curve > rotate > OK

Merge Entities

     Selected Features Insert > Features > Combine > select entities > OK

Trim Entities

     Curves Insert > Features > Split > select curve > OK

     Surfaces Insert > Features > Split > select surface > OK

Pattern Features

     Dimension Insert > Pattern/ Mirror > linear > OK

     Table Insert > Pattern/ Mirror > load table pattern coordinates > OK

     Reference Insert > Pattern/Mirror > Sketch Driven Pattern > Use sketch as reference > OK

Projections

     Datum Curves

          By sketch Insert > Curve > Projected > follow cues > OK

          By selection Insert > Curve > Projected > select curves follow cues > OK

Create a Wrap

     Datum Curves Insert > Feature > Wrap > follow cues > OK

Create Extensions

     Surface Insert > Surface > Extend > follow cues > OK

     Tangent Surfaces Insert > Surface > Extend > follow cues > OK

     To a Plane Insert > Surface > Extend Up to a surface or plane > follow cues > OK

Create Intersections from

     Sketches In sketcher Tools > Sketch Tools > Intersection Curve > OK

     Surfaces In sketcher Tools > Sketch Tools > Intersection Curve > OK

Create Fills Insert > Surface > Fill > follow cues > OK

Redefine a Fills In Part tree > right click and select Edit feature > OK

Create Offset 

     Surface

          Standard Insert > Surface > Offset > set distance > OK

          Expanded Insert > Surface > Offset > set distance > OK

          Constraints Insert > Surface > Offset > set distance > OK

          Drafts Insert > Surface > Offset > set distance > OK

          Replacing Insert > Surface > Offset > set distance > OK

     Curves

          Normal In sketcher click on Offset Entities tool > Pick edges and distance > OK

          Along In sketcher click on Offset Entities tool > Pick edges and distance > OK

          Fan Curve In sketcher click on Offset Entities tool > Pick edges and distance > OK

          Boundary In sketcher click on Offset Entities tool > Pick edges and distance > OK

          Variable Boundary In sketcher click on Offset Entities tool > Pick edges and distance > OK

Create a Thicken Insert > Base (or Boss) > Thicken.

Create a Solid on surfaces

     Protrusion Insert > Surface > Fill pick solid > OK

     Cut Insert > Surface > Fill pick remove material > OK

     Patches Insert > Surface > Fill pick remove/ Add material > OK

Create Holes 

     Sketched Insert > Sketch > draw hole to extrude > set end conditions > remove material > OK

     Simple Insert > Features > Hole > Simple > OK

     Counterbore Insert > Features > Hole > Counterbore > OK.

     Countersunk Insert > Features > Hole > countersunk > OK.

Create Shells

     Shells Insert > Features > Shell > OK

Create Ribs

     Ribs Insert > Features > Rib > OK

Create Drafts

     Standard Insert > Features > Draft > follow cues neutral > OK

     Variable Insert > Features > Draft > follow cues  > OK

     Split Insert > Features > Draft > follow cues > OK

          Split with 2 Hinge Planes Insert > Features > Draft > follow cues > OK

Create Rounds

     Basic Insert > Features > Fillet/Round > OK

Create Chamfers

     Basic Insert > Features > Chamfer > OK


